WordPress ElasticPress plugin <= 3.5.3 - Nonce Check Bypass vulnerability

elasticpress

Software
ElasticPress
Versions
<= 3.5.3
Disclosure date
2021-02-12
CVE
CVE-N/A
Credits
Classification
Bypass Vulnerability
OWASP Top 10
A2: Broken Authentication and Session Management

Are your websites subject to this vulnerability?

Details

Nonce Check Bypass vulnerability found by Felipe Elia in WordPress ElasticPress plugin (versions <= 3.5.3).

Solution

Update the WordPress ElasticPress plugin to the latest available version (at least 3.5.4).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.