WordPress Easy Registration Forms plugin <= 2.1.1 - Cross-Site Request Forgery (CSRF) vulnerability leading to Stored Cross-Site Scripting (XSS)

easy-registration-forms

Software
Easy Registration Forms
Vulnerable Versions
<= 2.1.1
Fixed in version
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A5: Broken Access Control
Disclosure Date
2021-11-18
CVSS 3.0 score

8.8

High

Plugin does not exist, is not supported or discontinued.

Are your websites subject to this vulnerability?

Details

Cross-Site Request Forgery (CSRF) vulnerability leading to Stored Cross-Site Scripting (XSS) discovered by Thinkland Security Team in WordPress Easy Registration Forms plugin (versions <= 2.1.1).

Solution

Deactivate and delete. This plugin has been closed as of November 12, 2021 and is not available for download. This closure is temporary, pending a full review.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.