WordPress Login/Signup Popup plugin <= 2.2 - Cross-Site Request Forgery (CSRF) vulnerability leading to Arbitrary Options Update

easy-login-woocommerce

Software
Login/Signup Popup
Vulnerable Versions
<= 2.2
Fixed in version
2.3
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A5: Broken Access Control
Disclosure Date
2022-01-13
CVSS 3.0 score

8.8

High

Are your websites subject to this vulnerability?

Details

Cross-Site Request Forgery (CSRF) vulnerability leading to Arbitrary Options Update discovered by Chloe Chamberland (Wordfence) in WordPress Login/Signup Popup plugin (versions <= 2.2).

Solution

Update the WordPress Login/Signup Popup plugin to the latest available version (at least 2.3).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.