WordPress Easy Cookies Policy plugin <= 1.6.2 - Broken Access Control vulnerability leading to Stored Cross-Site Scripting (XSS)

easy-cookies-policy

Software
Easy Cookies Policy
Vulnerable Versions
<= 1.6.2
Fixed in version
CVE
CVE-2021-24405
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A5: Broken Access Control
Disclosure Date
2021-06-11
CVSS 3.0 score

6.5

Medium

Can be exploited remotely without any authentication.

Plugin does not exist, is not supported or discontinued.

Are your websites subject to this vulnerability?

Details

Broken Access Control vulnerability leading to Stored Cross-Site Scripting (XSS) discovered by 0xB9 in WordPress Easy Cookies Policy plugin (versions <= 1.6.2).

Solution

This plugin has been closed as of April 28, 2021 and is not available for download. This closure is temporary, pending a full review.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.