WordPress Duplicator plugin <= 1.2.40 - Arbitrary Code Execution vulnerability

duplicator

Software
Duplicator
Vulnerable Versions
<= 1.2.40
Fixed in version
1.2.42
Classification
Arbitrary Code Execution
OWASP Top 10
A1: Injection
Disclosure Date
2018-09-05
CVSS 3.0 score

9.8

Critical

Can be exploited remotely without any authentication if installer.php and installer-backup.php are left on the server.

Plugin does not exist, is not supported or discontinued.

Are your websites subject to this vulnerability?

Details

Arbitrary Code Execution vulnerability found in WordPress Duplicator plugin (versions <= 1.2.40).

Solution

Update the WordPress Duplicator plugin to the latest available version (at least 1.2.42).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.