WordPress Download Manager plugin <= 3.2.33 - Authenticated SQL injection (SQLi) vulnerability to Reflected XSS vulnerability

download-manager

Software
Download Manager
Vulnerable Versions
<= 3.2.33
Fixed in version
3.2.34
Classification
SQL Injection
OWASP Top 10
A1: Injection
Disclosure Date
2022-01-12
CVSS 3.0 score

5.9

Medium

Requires high role user authentication like admin.

Are your websites subject to this vulnerability?

Details

Authenticated SQL injection (SQLi) vulnerability to Reflected XSS vulnerability discovered by Krzysztof Zając in WordPress Download Manager plugin (versions <= 3.2.33).

Solution

Update the WordPress Download Manager plugin to the latest available version (at least 3.2.34).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.