WordPress Directorist plugin <= 7.0.6.1 - Cross-Site Request Forgery (CSRF) vulnerability leading to Remote File Upload

directorist

Software
Directorist
Vulnerable Versions
<= 7.0.6.1
Fixed in version
7.0.6.2
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A5: Broken Access Control
Disclosure Date
2021-11-18
CVSS 3.0 score

8.8

High

Are your websites subject to this vulnerability?

Details

Cross-Site Request Forgery (CSRF) vulnerability leading to Remote File Upload discovered by lostbytes1 in WordPress Directorist plugin (versions <= 7.0.6.1).

Solution

Update the WordPress Directorist plugin to the latest available version (at least 7.0.6.2).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.