WordPress Defender Security Plugin <= 2.4.6 is vulnerable to Cross Site Request Forgery (CSRF)

Patch priority: low
Resolve by 31 March, 2021 Low priority
Not known to be exploited Report an attack
4.3
Medium severity CVSS 3.1 score

Patchstack is the official security point of contact for this software.

Enable Protection

Patchstack is the official security point of contact for WordPress Defender Security plugin.

Solution

Fixed Update to fix

Update the WordPress Defender Security plugin to the latest available version (at least 2.4.6.1).

NintechNet discovered and reported this Cross Site Request Forgery (CSRF) vulnerability in WordPress Defender Security Plugin. This could allow a malicious actor to force higher privileged users to execute unwanted actions under their current authentication. This vulnerability has been fixed in version 2.4.6.1.

Have additional information or questions about this entry? Get in touch.

Other vulnerabilities in this plugin

0 present
5 fixed
View all

WordPress plugin developer?

Start a free security program for your WordPress plugins or request an audit.

Apply for MVDP

Security researcher?

Report to Patchstack Bug Bounty to earn bounties and rewards!

Learn more
Mobile Menu

Let us know if we have missed a vulnerability reported elsewhere

Mobile Menu Close

Thank you for contributing!

Close Mobile Menu