WordPress Database Backups plugin <= 1.2.2.6 - Cross-Site Request Forgery (CSRF) vulnerability leading to backup download

database-backups

Software
Database Backups
Versions
<= 1.2.2.6
Disclosure date
2021-03-10
CVE
CVE-2021-24174
References
Credits
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A2: Broken Authentication
CVSS 3.0 score

6.1

Medium

Plugin does not exist, is not supported or discontinued.

Are your websites subject to this vulnerability?

Details

Cross-Site Request Forgery (CSRF) vulnerability leading to backup download discovered by 0xB9 in WordPress Database Backups plugin (versions <= 1.2.2.6).

Solution

2021-03-18 - we were unable to find a patched version of this plugin. WordPress.org plugin repository notice: "This plugin has been closed as of February 10, 2021 and is not available for download. This closure is temporary, pending a full review."

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.