WordPress Custom Post View Generator plugin <= 0.4.6 - Reflected Cross-Site Scripting (XSS) vulnerability

custom-post-view-generator

Software
Custom Post View Generator
Vulnerable Versions
<= 0.4.6
Fixed in version
CVE
CVE-2021-24605
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2021-09-10
CVSS 3.0 score

6.2

Medium

Plugin does not exist, is not supported or discontinued.

Are your websites subject to this vulnerability?

Details

Reflected Cross-Site Scripting (XSS) vulnerability discovered by Neppah in WordPress Custom Post View Generator plugin (versions <= 0.4.6).

Solution

This plugin has been closed as of August 3, 2021 and is not available for download. This closure is temporary, pending a full review.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.