WordPress WPCS plugin <= 1.1.6 - Cross-Site Request Forgery (CSRF) vulnerability

currency-switcher

Software
WPCS
Vulnerable Versions
<= 1.1.6
Fixed in version
1.1.7
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A8: Cross Site Request Forgery (CSRF)
Disclosure Date
2021-07-06
CVSS 3.0 score

4.3

Medium

Are your websites subject to this vulnerability?

Details

Cross-Site Request Forgery (CSRF) vulnerability discovered by Mizuki Takagi (Cryptography Laboratory, Tokyo Denki University) in WordPress WPCS plugin (versions <= 1.1.6).

Solution

Update the WordPress WPCS plugin to the latest available version (at least 1.1.7).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.