WordPress Countdown and CountUp, WooCommerce Sales Timer plugin <= 1.5.7 - Cross-Site Request Forgery (CSRF) leading to Stored Cross-Site Scripting (XSS)

countdown-wpdevart-extended

Software
Countdown and CountUp, WooCommerce Sales Timer
Vulnerable Versions
<= 1.5.7
Fixed in version
1.5.8
CVE
CVE-2021-34636
Credits
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A8: Cross Site Request Forgery (CSRF)
Disclosure Date
2021-09-27
CVSS 3.0 score

8.8

High

Are your websites subject to this vulnerability?

Details

Cross-Site Request Forgery (CSRF) vulnerability leading to Stored Cross-Site Scripting (XSS) discovered by Xu-Liang Liao in WordPress Countdown and CountUp, WooCommerce Sales Timer plugin (versions <= 1.5.7).

Solution

Update the WordPress Countdown and CountUp, WooCommerce Sales Timer plugin to the latest available version (at least 1.5.8).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.