WordPress Comment Rating Plugin 2.9.23 - Multiple Vulnerabilities

comment-rating

Software
Comment Rating
Versions
2.9.23
Disclosure date
2011-02-23
CVE
CVE-N/A
References
Classification
Multiple Vulnerabilities
OWASP Top 10

Are your websites subject to this vulnerability?

Details

There are several vulnerabilities in this plugin. First vulnerability type is path disclosure. The issue exists due to failure in the "/wp-content/plugins/comment-rating/comment-rating-options.php" script. There is possible to generate an error which will disclose the full path of the script. In this way an attacker can approach potentially information. Second vulnerability type is SQL injection. The vulnerability exists because of failure in the "/wp-content/plugins/comment-rating/ck-processkarma.php" script to properly clean up user-supplied input in "id" variable. It allows an attacker to modify data, alter queries to the application SQL database, compromise the access and application or exploit hidden vulnerabilities in the underlying database.

Solution

Upgrade the plugin to the most recent version.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.