API Monitor free
arrow right To plugin page
Not fixed

WordPress Code Snippets Extended plugin <= 1.4.7 - Cross-Site Request Forgery (CSRF) vulnerability leading to Persistent Cross-Site Scripting (XSS)

4.7
CVSS 3.1 score Medium severity
Monitoring Coming soon

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Software
Code Snippets Extended
Type
Plugin
Vulnerable versions
<= 1.4.7
Fixed in
N/A
PSID
21f6dab74445
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A5: Broken Access Control
Publicly disclosed
2022-05-17

Details

Cross-Site Request Forgery (CSRF) vulnerability leading to Persistent Cross-Site Scripting (XSS) was discovered by BEE-K (Patchstack) in WordPress Code Snippets Extended plugin (versions <= 1.4.7).

Solution

Deactivate and delete. No patched version is available. No reply from the vendor.

References

CVE-2022-29436 Plugin page

Other known vulnerabilities for Code Snippets Extended

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close