WordPress Spam protection, AntiSpam, FireWall by CleanTalk plugin <=5.127.3 - Cross-Site Scripting (XSS) vulnerability

cleantalk-spam-protect

Software
Spam protection, AntiSpam, FireWall by CleanTalk
Versions
<=5.127.3
Disclosure date
2019-11-14
CVE
CVE-2019-17515
References
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A3: Cross Site Scripting (XSS)

Are your websites subject to this vulnerability?

Details

Cross-Site Scripting (XSS) vulnerability found in WordPress Spam protection, AntiSpam, FireWall by CleanTalk plugin (versions <=5.127.3).

Solution

Update the WordPress Spam protection, AntiSpam, FireWall by CleanTalk plugin to the latest available version (at least 5.127.4).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.