WordPress amtyThumb plugin <= 4.2.0 - Authenticated SQL Injection (SQLi) vulnerability

amtythumb

Software
amtyThumb
Vulnerable Versions
<= 4.2.0
Fixed in version
Classification
SQL Injection
OWASP Top 10
A1: Injection
Disclosure Date
2022-05-12
CVSS 3.0 score

6.6

Medium

Requires author or higher role user authentication.

Plugin does not exist, is not supported or discontinued.

Are your websites subject to this vulnerability?

Details

Authenticated SQL Injection (SQLi) vulnerability was discovered by Daniel Krohmer (Fraunhofer IESE, Germany) and Shi Chen (University of Kaiserslautern, Germany) in the WordPress amtyThumb plugin (versions <= 4.2.0).

Solution

Deactivate and delete. This plugin has been closed as of May 12, 2022 and is not available for download. This closure is temporary, pending a full review.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.