WordPress All 404 Redirect to Homepage plugin <= 1.21 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability

all-404-redirect-to-homepage

Software
All 404 Redirect to Homepage
Versions
<= 1.21
Disclosure date
2021-06-01
CVE
CVE-N/A
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
CVSS 3.0 score

4.8

Medium

Requires high privilege user.

Plugin does not exist, is not supported or discontinued.

Are your websites subject to this vulnerability?

Details

Authenticated Stored Cross-Site Scripting (XSS) vulnerability discovered by WPScanTeam in WordPress All 404 Redirect to Homepage plugin (versions <= 1.21).

Solution

This plugin has been closed as of June 1, 2021 and is not available for download. This closure is temporary, pending a full review.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.