WordPress Ivory Search plugin <= 4.6 - Reflected Cross-Site Scripting (XSS) vulnerability

add-search-to-menu

Software
Ivory Search
Versions
<= 4.6
Disclosure date
2021-03-30
CVE
CVE-2021-24234
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
CVSS 3.0 score

7.4

High

Are your websites subject to this vulnerability?

Details

Reflected Cross-Site Scripting (XSS) vulnerability discovered by Jinson Varghese Behanan in WordPress Ivory Search plugin (versions <= 4.6).

Solution

Update the WordPress Ivory Search plugin to the latest available version (at least 4.6.1).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.