WordPress Ad Invalid Click Protector (AICP) plugin <= 1.2.5.2 - SQL injection (SQLi) vulnerability

ad-invalid-click-protector

Software
Ad Invalid Click Protector (AICP)
Vulnerable Versions
<= 1.2.5.2
Fixed in version
1.2.6
Classification
SQL Injection
OWASP Top 10
A1: Injection
Disclosure Date
2022-01-12
CVSS 3.0 score

4.7

Medium

Requires high role user authentication like admin.

Are your websites subject to this vulnerability?

Details

SQL injection (SQLi) vulnerability discovered by Krzysztof Zając in WordPress Ad Invalid Click Protector (AICP) plugin (versions <= 1.2.5.2).

Solution

Update the WordPress Ad Invalid Click Protector (AICP) plugin to the latest available version (at least 1.2.6).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.