WordPress 404 to 301 plugin <= 3.0.8 - Cross-Site Request Forgery (CSRF) vulnerability leading to Logs Deletion

404-to-301

Software
404 to 301
Vulnerable Versions
<= 3.0.8
Fixed in version
3.0.9
CVE
CVE-2021-24766
Credits
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A8: Cross Site Request Forgery (CSRF)
Disclosure Date
2021-10-11
CVSS 3.0 score

5.4

Medium

Are your websites subject to this vulnerability?

Details

Cross-Site Request Forgery (CSRF) vulnerability leading to Logs Deletion discovered by apple502j in WordPress 404 to 301 plugin (versions <= 3.0.8).

Solution

Update the WordPress 404 to 301 plugin to the latest available version (at least 3.0.9).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.