better-auth <= 1.2.9 is vulnerable to Open Redirection

Low priority No impactful threat
<= 1.2.9Vulnerable version(s)
1.2.10Patched version
7 Jul, 2025

Get the fastest vulnerability mitigation with Patchstack!

Get started

Risks

CVSS 2.1

As immediate action, update the affected plugin. If you're unable to do so, ask your hosting provider or web developer for help.

2.1

Open Redirection

Your website can be abused to redirect visitors to fake or malicious sites, enabling scams.

CVSS score is a way to evaluate and rank reported vulnerabilities in a standardized and repeatable way but which is not ideal for WordPress.

Solutions

This security issue has a low severity impact and is unlikely to be exploited.

Update to version 1.2.10 or later.

Update to version 1.2.10 or later to resolve the vulnerability.

Details

Have additional information or questions about this entry? Let us know.

Timeline

Published by Patchstack

7 Jul, 2025

Weekly WordPress security intelligence delivered to your inbox.