Security programs Bounty leaderboard API Protect

WordPress I Recommend This Plugin <= 3.8.3 is vulnerable to Cross Site Scripting (XSS)

This plugin was still closed for Security Reason as of October 27th 2023. A patch was added in plugin version 3.9.0, but this version isn't available yet. Alternatively, it can be downloaded at

Patch within 30 days Low priority
Not known to be exploited Report an attack
Medium severity CVSS 3.1 score

Patchstack is the official security point of contact for this software.

Enable Protection

Patchstack is the official security point of contact for WordPress I Recommend This plugin.


Update to fix

Update the WordPress I Recommend This plugin to the latest available version (at least 3.9.0).

Found this useful? Thank Rio Darmawan for reporting this vulnerability. Buy a coffee ☕


Show technical details

Rio Darmawan discovered and reported this Cross Site Scripting (XSS) vulnerability in WordPress I Recommend This Plugin. This could allow a malicious actor to inject malicious scripts, such as redirects, advertisements, and other HTML payloads into your website which will be executed when guests visit your site. This vulnerability has been fixed in version 3.9.0.

Other vulnerabilities in this plugin

1 present
2 patched
View all

WordPress plugin developer?

Start a free security program for your WordPress plugins or request an audit.

Apply for MVDP

Security researcher?

Report to Patchstack Alliance bounty platform and earn monthly cash prizes.

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close